通达信aPP均线主图公式

如何编辑自己的通达信软件均线主图指标

MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);
MA5:MA(CLOSE,M5);
MA6:MA(CLOSE,M6);
MA7:MA(CLOSE,M7);
MA8:MA(CLOSE,M8);
MA9:MA(CLOSE,M9);
MA10:MA(CLOSE,M10);
用上面的公式新建指标,参数M1-M10,最小0,最大1000,缺省自行设定,公式里可以画10条均线,不需要这么多的话,缺省设为0,这条线就不显示了
画图方式:主图叠加

求教高手帮忙编个:通达信的主图如何显示均线角度公式,并保留原均线不变

第一种:
MA5:MA(CLOSE,5),DOTLINE,COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORMAGENTA;
MA30:MA(CLOSE,30),COLORBLUE;
MA60:MA(CLOSE,60),COLORRED,DOTLINE,LINETHICK1;
MA120:MA(CLOSE,120),COLORGREEN;
MA250:MA(CLOSE,250),COLORMAGENTA,DOTLINE,LINETHICK1;
IF(MA60>REF(MA60,1),MA60,DRAWNULL),COLORRED,LINETHICK2;
TQ1:(ATAN((MA(C,10)/REF(MA(C,10),1)-1)*100)*180/3.14115926)NODRAW,COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND TQ1,0.0,0,0,'【十日线角度】'),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1 AND TQ1,0.08,0,0,TQ1),COLORWHITE;
第二种
MA5:MA(CLOSE,5),DOTLINE,COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORMAGENTA;
MA30:MA(CLOSE,30),COLORBLUE;
MA60:MA(CLOSE,60),COLORRED,DOTLINE,LINETHICK1;
MA120:MA(CLOSE,120),COLORGREEN;
MA250:MA(CLOSE,250),COLORMAGENTA,DOTLINE,LINETHICK1;
IF(MA60>REF(MA60,1),MA60,DRAWNULL),COLORRED,LINETHICK2;
十日线角度:(ATAN((MA(C,10)/REF(MA(C,10),1)-1)*100)*180/3.14115926),NODRAW,COLORWHITE;

怎么编写通达信炒股软件的主图指标

假设三条线分别的线1,线2,线3(假设是ma(c,3),ma(c,4),ma(c,5))
用条件语句,
if(线1>线2,线2,drawnull); 意思时如果线1>线2,输出线2,否则不输出
if(线2>线3,线2,drawnull); 意思时如果线2>线3,输出线2,否则不输出
if(线1>ref(线1,),线2,drawnull); 意思时如果线1>昨天线1,输出线2,否则不输出
这样的话不是三条线都输出成一条了吗?

求教高手帮忙编个:通达信的主图如何显示均线角度公式

你并没有说事那条线的角度,下面的公式是5日线的角度公式,自己参照着做:
ma5:=(c,5);
五日线角度:atan((ma5/ref(ma5,1)-1)*100)*180/3.1416;

通达信公式在下面公式里面加上ma均线

VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'买入'),COLORRED;
S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
DRAWTEXT(卖1>0,HIGH*1.02,'卖出'),COLORGREEN;
{股灵吧决策}
VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));
A:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
A0:=(AH-AL)/40;
B1:=L-A0;
STICKLINE((A+0)/34=FLOOR((A+0)/34),B1,B1-1.5*A0,3,0),COLORF00FF0;
DRAWTEXT((A+0)/34=FLOOR((A+0)/34),B1-1*A0,'时间窗'),COLORWHITE;
ma:ma(c,5) ;

请高手写一个通达信的CCI加均线MA的公式

MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
A:=CCI.CCI;
DRAWICON(CROSS(MA1,MA2) AND A<-100,MA1,1);
DRAWICON(CROSS(MA2,MA1) AND A>100,MA1,2);

公式已测试通过!
希望能够帮助你!

效果图如下: