通达信流通股本主图公式

通达信的流通盘Z如何在公式中表述?

流通市值Z: 自由流通市值,流通市值 减去 流通股东占5%以上股份的市值

请高手编一个:能显示所属板块指标的通达信主图公式,谢谢!

{说明:通达信最新版可用}

MA1:MA(CLOSE,5);

MA2:MA(CLOSE,10);

MA3:MA(CLOSE,20);

MA4:MA(CLOSE,60);

HH:=CONST(HHV(H,160));

LL:=CONST(LLV(L,160));{160可改成你习惯锁定的日K线数}

HL1:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.76,0.04));

HL2:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.80,0.08));

HL3:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.84,0.12));

HL4:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.88,0.16));

HL5:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.92,0.20));

HL6:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.96,0.24));

DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR0080FF;

DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR0080FF;

DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;

DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;

DRAWTEXT_FIX(1,0.00,0.04,0,'主题投资:')COLOR0000FF;

DRAWTEXT_FIX(1,0.07,0.04,0,EXTERNSTR(0,1))COLOR0000FF;

DRAWTEXT_FIX(1,0.00,0.08,0,'主营业务:')COLORFF00FF;

DRAWTEXT_FIX(1,0.07,0.08,0,EXTERNSTR(0,2))COLORFF00FF;

DRAWTEXT_FIX(1,0.00,0.12,0,'出千概念:')COLORFF88FF;

DRAWTEXT_FIX(1,0.07,0.12,0,EXTERNSTR(0,3))COLORFF88FF;

DRAWTEXT_FIX  (1,0.80,HL1,0,'股本:');

DRAWNUMBER_FIX(1,0.84,HL1,0,CONST(FINANCE(1)/100000000));

DRAWTEXT_FIX  (1,0.80,HL2,0,'流通:');

DRAWNUMBER_FIX(1,0.84,HL2,0,CONST(FINANCE(7)/100000000));

DRAWTEXT_FIX  (1,0.80,HL3,0,'动PE:');

DRAWNUMBER_FIX(1,0.84,HL3,0,CONST(DYNAINFO(39)));

DRAWTEXT_FIX  (1,0.80,HL4,0,'换手:');

DRAWNUMBER_FIX(1,0.84,HL4,0,CONST(DYNAINFO(37)*100));

DRAWTEXT_FIX  (1,0.80,HL5,0,'量比:');

DRAWNUMBER_FIX(1,0.84,HL5,0,CONST(DYNAINFO(17)));

DRAWTEXT_FIX  (1,0.80,HL6,0,'涨幅:');

DRAWNUMBER_FIX(1,0.84,HL6,0,CONST(DYNAINFO(14)*100)),COLORFF00FF;

DRAWNUMBER_FIX(1,0.84,HL6,0,IF(CONST(DYNAINFO(14)*100)<0,CONST(DYNAINFO(14)*100),DRAWNULL))COLOR00FF00;

请教通达信选股公式:总股本=流通股本,或者是总市值=流通市值的选股公式

FINANCE(1)=FINANCE(7) or FINANCE(41) =FINANCE(40) ;

求通达信流通盘小于20亿的选股公式.

只要排序就行了!我发了一个图,你看看!

广发证券老鸭头选股公式

你做的怎么样呢

求老鸭头选股公式,在广发至强版编写的祥细公式,麻烦测试一下

VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,60);
VAR4:=BARSLAST(CROSS(VAR1,VAR3));
VAR5:=BARSLAST(CROSS(VAR2,VAR3));
VAR6:=BARSLAST(HIGH=HHV(HIGH,VAR5));
VAR7:=BARSLAST(CROSS(VAR2,VAR1));
VAR8:=BARSLAST(CROSS(VAR1,VAR2));
VAR9:=VAR4>VAR5 AND VAR5>VAR6 AND VAR6>VAR7 AND VAR7>VAR8 AND VAR8<5;
VARA:=COUNT(CROSS(VAR2,VAR1),VAR5)=1;
老鸭头:VAR9 AND VARA AND VAR3>REF(VAR3,1);
(你试试看)